AWS Service Destruction

Incident Report for Phoenix Ascend

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 22:00 UTC

Monitoring

AWS Downtime
Posted Apr 13, 2026 - 21:41 UTC
This incident affected: Athena Analyzer, Clinical Portal, and API.